Elmer
Alternative Pre-processing tools

ElmerTeam
CSC – IT Center for Science
Mesh generation capabilities of Elmer suite

- **ElmerGrid**
  - native generation of simple structured meshes

- **ElmerGUI**
  - plugins for tetgen, netgen and ElmerGrid

- No geometry generation tools to speak about
- No capability for multibody Delaunay meshing
- Limited control over mesh quality and density

- Complex meshes must be created by other tools!
Open Source software for Computational Engineering

- Open CASCADE Technology
- OpenFOAM
- ParaView
- Freefem++
- Visualization Toolkit
- Code_Aster
- Gmsh
- deal.II
- Netgen Mesh Generator
- Qt
- Trilinos
- Elmer
- PETSc
- Fenics Project
- libMesh
- Python
Open source software in computational engineering

- Academicly rooted stuff is top notch
  - Linear algebra, solver libraries
  - PetSc, Trilinos, OpenFOAM, LibMesh++, ...

- CAD and mesh generation not that competitive
  - OpenCASCADE legacy software
  - Mesh generators netgen, tetgen, Gmsh are clearly academic
  - Also for OpenFOAM there is development of commercial preprocessing tools

- Users may need to build their own workflows from the most suitable tools
  - Also in combination with commercial software
Open Source Mesh Generation Software for Elmer

- **ElmerGrid**: native to Elmer
  - Simple structured mesh generation
  - Simple mesh manipulation
  - Usable via ElmerGUI

- **ElmerMesh2D**
  - Obsolite 2D Delaunay mesh generator usable via the old ElmerFront

- **Netgen**
  - Can write linear meshes in Elmer format
  - Usable also as ElmerGUI plug-in

- **Tetgen**
  - Usable as ElmerGUI plug-in

- **Gmsh**
  - Includes geometry definition tools
  - ElmerGUI/ElmerGrid can read the format msh format

- **SALOME**
  - ElmerGrid can read the unv format written by SALOME

- **Triangle**
  - 2D Delaunay
  - ElmerGUI/ElmerGrid can read the format
Commercial mesh generation software for Elmer

- **GiD**
  - Relatively inexpensive
  - With an add-on module can directly write Elmer format

- **Comsol multiphysics**
  - ElmerGUI/ElmerGrid can read .mphtxt format

- ...

Ask for your format:
  - Writing a parser from ascii-mesh file usually not big a deal
# Mesh generation tools – Poll (5/2017)

<table>
<thead>
<tr>
<th>Mesh generation software</th>
<th>Votes</th>
<th>Percentage</th>
</tr>
</thead>
<tbody>
<tr>
<td>ElmerGUI (netgen or tetgen plugins)</td>
<td>10</td>
<td>9%</td>
</tr>
<tr>
<td>Gmsh</td>
<td>46</td>
<td>43%</td>
</tr>
<tr>
<td>Netgen</td>
<td>11</td>
<td>10%</td>
</tr>
<tr>
<td>ElmerGrid (native .grd format)</td>
<td>9</td>
<td>8%</td>
</tr>
<tr>
<td>GiD</td>
<td>1</td>
<td>1%</td>
</tr>
<tr>
<td>Ansys</td>
<td>3</td>
<td>3%</td>
</tr>
<tr>
<td>Gambit</td>
<td>0</td>
<td>No votes</td>
</tr>
<tr>
<td>Comsol Multiphysics</td>
<td>1</td>
<td>1%</td>
</tr>
<tr>
<td>Salome</td>
<td>22</td>
<td>20%</td>
</tr>
<tr>
<td>Something else (please specify)</td>
<td>5</td>
<td>5%</td>
</tr>
</tbody>
</table>

Total votes : 108
SALOME is an open-source software that provides a generic platform for Pre- and Post-Processing for numerical simulation. It is based on an open and flexible architecture made of reusable components.

SALOME is a cross-platform solution. It is distributed as open-source software under the terms of the GNU LGPL license. You can download both the source code and the executables from this site.

SALOME can be used as standalone application for, or as a platform for integration of the external third-party numerical codes.
Using Salome with Elmer

There are some instructions in Wiki


- The .unv format provides a channel from Salome to Elmer
  - ElmerGrid 8 2 test.unv --autoclean
  - Or direct opening with ElmerGUI

- Unv import of ElmerGrid tries to maintain the names and save them to mesh.names file of mesh directory
  - Set ”Use Mesh Names = True” to Simulation section

- There is active development of Elmer plug-in by the open source community
  - Follow discussion on the Elmer forum
Gmsh

http://gmsh.info

Written by Christophe Geuzaine and Jean-François Remacle

Gmsh is a free 3D finite element grid generator with a build-in CAD engine and post-processor

Its design goal is to provide a fast, light and user-friendly meshing tool with parametric input

Gmsh is built around four modules: geometry, mesh, solver and post-processing.

The specification of any input to these modules is done either interactively using the graphical user interface or in ASCII text files using Gmsh's own scripting language.

Probably the most popular academic mesh generation for finite element method
Using Gmsh with Elmer

- Saving of the mesh in native gmsh format
  - Suffix .msh
- Usually saving all geometric entities is most robust method
  - Elmer automatically drops lower dimensional entities
  - Elmer renumbers BCs and bodies with 1,2,3,...

In practice:

In Gmsh:
File -> Save as
  Filename: test.msh
  MSH Options
  Version 2.0 ASCII
  Save all (ignore physical groups)

In ElmerGUI
File -> Open : test.msh

Or ElmerGrid:
**ElmerGrid 14 2 test.msh -autoclean**
(creates a mesh file in directory test)
Example: exporting tutorial 2 of Gmsh
Exercise: Gmsh to Elmer export

- Start gmsh.exe
- Load a existing tutorial in Gmsh
  - t1-t6
- Create the default mesh for it
  - Mesh -> 1D, 2D, (3D)
  - A global size factor may be found at
    Options – Mesh – General – Max. Element size
- Open the mesh in ElmerGUI
- Perform a simple thermal analysis if you have time

Tutorial 2 of Gmsh
Netgen

http://www.hpfem.jku.at/netgen/

- Developed mainly by Joachim Schöberl
- An automatic 2D/3D tetrahedral mesh generator
- Accepts input from constructive solid geometry (CSG) or boundary representation (BRep) from STL file format
- Connection to OpenCASCADE deals with IGES and STEP files
- Modules for mesh optimization and mesh refinement
- LGPL library
- Netgen as a library is utilized by a large number of GUI projects
- Directly writes meshes in Elmer format (linear only)
GiD

http://www.gidhome.com

- GiD is developed at CIMNE, Barcelona
- GiD is a universal, adaptive and user-friendly pre and postprocessor for numerical simulations in science and engineering.
- Designed to cover all the common needs in the numerical simulations field from pre to post-processing: geometrical modeling, effective definition of analysis data, meshing, data transfer to analysis software, as well as the visualization of numerical results.
- A good compromise between features and price
- Enables creation of hybrid meshes (not well supported in Gmsh)
- Elmer plugin for writing meshes in Elmer exists
Using GID with Elmer

- Requires special plugins that enable problemtype "Elmer"
- Saves Elmer mesh files directly
- For more details see: http://www.csc.fi/english/pages/elmer/interfaces
Summary of Pre-Processing Workflows in Elmer

- Simple structured
  - ElmerGrid -> ElmerSolver

- Intermediate academic
  - Gmsh -> ElmerGrid/ElmerGUI -> ElmerSolver

- Complex free
  - SALOME -> ElmerGrid -> ElmerSolver

- Complex commercial
  - GiD -> ElmerSolver

- And many more....
Elmer

Post-processing utilities

ElmerTeam
CSC – IT Center for Science
Visualization capabilities of Elmer suite

ElmerPost was basically ok but had some limitations
- Somewhat outdated look and feel
- Output resolution same as window resolution
- Only one view at a time
- No parallel functionality
- Some compilation challenges

VTK-widget in ElmerGUI
- Minimalistic visualization mimicking ElmerPost functionality
- Nice as an integrated tool for educational purposes
- Not actively developed

Visualization tools beyond Elmer suite as mainly used
- Tools based on VTK library!
## Visualization tools – Poll (5/2017)

What visualization software do you use?

<table>
<thead>
<tr>
<th>Software</th>
<th>Votes</th>
<th>Percentage</th>
</tr>
</thead>
<tbody>
<tr>
<td>ElmerPost</td>
<td>14</td>
<td>16%</td>
</tr>
<tr>
<td>ElmerGUI VTK postprocessor</td>
<td>9</td>
<td>11%</td>
</tr>
<tr>
<td>Paraview</td>
<td>37</td>
<td>44%</td>
</tr>
<tr>
<td>ViSit</td>
<td>3</td>
<td>4%</td>
</tr>
<tr>
<td>Mayavi</td>
<td>0</td>
<td>No votes</td>
</tr>
<tr>
<td>Gmsh</td>
<td>4</td>
<td>5%</td>
</tr>
<tr>
<td>GiD</td>
<td>1</td>
<td>1%</td>
</tr>
<tr>
<td>Matlab</td>
<td>7</td>
<td>8%</td>
</tr>
<tr>
<td>gnuplot</td>
<td>4</td>
<td>5%</td>
</tr>
<tr>
<td>Something else (please specify)</td>
<td>6</td>
<td>7%</td>
</tr>
</tbody>
</table>

Total votes: 85
Exporting FEM data: ResultOutputSolve

Apart from saving the results in .ep format it is possible to use other postprocessing tools.

ResultOutputSolve offers several formats:

- vtk: Visualization tookit legacy format
- vtu: Visualization tookit XML format
- Gid: GiD software from CIMNE: http://gid.cimne.upc.es
- Gmsh: Gmsh software: http://www.geuz.org/gmsh
- Dx: OpenDx software

**Vtu** is the recommended format!

- offers parallel data handling capabilities
- Has binary and single precision formats for saving disk space
- Suffix **.vtu** in Post File does this automatically
Exporting 2D/3D data: ResultOutputSolve

An example shows how to save data in unstructured XML VTK (.vtu) files to directory "results" in single precision binary format.

Solver n

`Exec Solver = after timestep`
`Equation = "result output"`
`Procedure = "ResultOutputSolve" "ResultOutputSolver"
`Output File Name = "case"
`Output Format = String "vtu"
`Binary Output = True
`Single Precision = True`

End

Basic functionality also just by adding suffix .vtu to the Post File in simulation section
ParaView

http://www.paraview.org

Developed by Kitware and US national labs (Los Alamos, Sandia, etc.)

ParaView is an open-source, multi-platform data analysis and visualization application based on VTK

Data exploration can be done interactively in 3D or programmatically using ParaView’s batch processing capabilities.

ParaView was developed to analyze extremely large datasets using distributed memory computing resources. It can be run both on supercomputers and laptops.

Most popular OS visualization tool for FEM data
ViSiT

https://visit.llnl.gov/

- Developed at Lawrence Livermore National Labs.
- VisIt is an open source, interactive, scalable, visualization, animation and analysis tool.
- From Unix, Windows or Mac workstations, users can interactively visualize and analyze data from small desktop projects to huge HPC projects
- VisIt contains a rich set of visualization features to enable users to view a wide variety 2D and 3D data, structured and un-structured meshes
## Comparison of visualization software

<table>
<thead>
<tr>
<th><strong>ParaView</strong></th>
<th><strong>VisIt</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Fulfils the standard needs for FEM simulation</td>
<td>Fulfils the standard needs for FEM simulation</td>
</tr>
<tr>
<td>Supports Elmer best via the VTU file format</td>
<td>Supports Elmer best via the VTU file format</td>
</tr>
<tr>
<td>Look and feel is very appealing</td>
<td>Look and feel may feel somewhat academic</td>
</tr>
<tr>
<td>Filters are applied directly after they have been selected</td>
<td>Whole workflow is applied only after request</td>
</tr>
<tr>
<td>— Interactive operation nice with small datasets</td>
<td>— Enables the software to better optimize the rendering process</td>
</tr>
<tr>
<td>Good 1st choice</td>
<td>Choice for powerusers?</td>
</tr>
</tbody>
</table>
Case: View in Paraview
Example: view in GiD
Example: view in Gmsh
Visualization with Paraview
Exporting 2D/3D data: ResultOutputSolve

By setting suffix for Post File to .vtu paraview format is saved automatically.

An example shows how to save data in unstructured XML VTK (.vtu) files to directory "results" in single precision binary format.

Solver n
  Exec Solver = after timestep
  Equation = "result output"
  Procedure = "ResultOutputSolve" "ResultOutputSolver"
  Output File Name = "case"
  Output Format = String "vtu"
  Binary Output = True
  Single Precision = True
  Save Geometry Ids = True
End
Filename conventions

- Suffix of unstructured XML based VTU file is `.vtu`
- Timesteps numbered `#step`
- Partitions numbered with `#part#par#step`
- Holder for vtu files in parallel is `.pvtu`
Note: Paraview may have several datasets at the same time!
Solid color
Moving object in Paraview

- **Rotate**
  - Mouse: Left bottom

- **Scale**
  - Mouse: Right bottom

- **Translate**
  - Mouse: Center bottom
Setting background color
Color mesh with surface + edges
Paraview uses extensively filters to create new datasets.

Filters and datasets may be set active or passive by clicking the eye.

Several datasets may be visualized at the same time.
Plotting a slice
Plotting a clip
Vector plot
Vector plot + opaque solid surface
Vector plot + solid surface with Id treshold
Change of colormap
Deformation – WarpByVector filter
Plot line – PlotOverLine filter
Streamlines – Filter StreamTracer
Partitioning – Connectivity filter
Memory consumption of vtu-files (for Paraview) was studied in the "swiss cheese" case.

Saving just boundaries in single precision binary format may save over 90% in files size compared to full data in ascii.

With larger problem sizes the benefits are amplified.

<table>
<thead>
<tr>
<th>Binary output</th>
<th>Single Prec.</th>
<th>Only bound.</th>
<th>Bytes/node</th>
</tr>
</thead>
<tbody>
<tr>
<td>-</td>
<td>X</td>
<td>-</td>
<td>376.0</td>
</tr>
<tr>
<td>X</td>
<td>-</td>
<td>-</td>
<td>236.5</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td>-</td>
<td>184.5</td>
</tr>
<tr>
<td>X</td>
<td>-</td>
<td>X</td>
<td>67.2</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td>X</td>
<td>38.5</td>
</tr>
</tbody>
</table>

Simulation Peter Råback, CSC, 2012.
Saving figures
Saving animations with Paraview

- The only packing method that comes with Paraview by default is motion AVI.
- It is advisable to save the animation as separate files.
- You may use ElmerClips to make mpg animations of the separate png figures.
Visualization with ElmerPost
How to write files for ElmerPost

- Default suffix is `.ep`
- May be requested in Simulation section
  Post File = case.ep
- Or using ResultOutputSolver with
  Output format = ElmerPost
Loading data

- Assume data in case.ep
- File -> Open -> case.ep
- Here the timesteps are chosen
- If element edges or sides are not defined for BCs they may have to be created here
Solid color
Moving object in ElmerPost

- **Rotate**
  - Mouse: Right bottom
  - Click: 🎵🎵🎵🎵
  - Command line, e.g.: `rotate 30 45 60`

- **Scale**
  - Mouse: Both bottoms
  - Click: 🎵🎵🎵🎵
  - Command line: `scale 1 10 1`

- **Translate**
  - Mouse: Left bottom
  - Click: 🎵🎵🎵🎵
  - Command line: `translate 1 2 3`
Setting background color

Click:
- Edit -> Background
- Set 100.0 100.0 100.0 for white

Command line
- `background 100 100 100`
Color mesh with surface + edges
Plotting isosurfaces
Using clip planes
Isosurface + surface plot + clip planes
Vector plots
Vector plot + solid surface
Surface plot + Isosurfaces + Opaque
Change of colormap
Selecting active geometric entities
Saving figures

File -> Save Image -> jpg
Deformation in geometry

- Assume displacement field in variable “Displacement”
- Set in command windows:
  
  ```
  math n0=nodes
  math nodes=n0+Displacement
  ```
- Replot
Conclusions

- Use Paraview and VTU format
- For large visualizations ViSiT could be an option
SALOME

- SALOME is an open-source software that provides a generic platform for Pre- and Post-Processing for numerical simulation.
- It can be used as standalone application for generation of CAD model, preparation for numerical calculations and post-processing of the calculation results.
- SALOME can also be used as a platform for integration of the external third-party numerical codes to produce a new application for the full life-cycle management of CAD models.

http://www.salome-platform.org/

- SALOME GUI functions can be extended with python plugins ➔ Elmer plugin for SALOME
Plugin developed by Rainer Jacob and Matthias Zenker

Available from GitHub (https://github.com/physici/ElmerSalomeModule)

Requirements

- Elmer 8.2 or 8.3
- Salome 7.8 or 8.2

Installation to the optional directory

1. Create a plugin directory in the root path of SALOME or somewhere convenient, if not already using one.
2. Copy 'ElmerSalome' directory into the plugin directory.
3. Copy the 'salome_plugins.py' file in the plugin directory or modify the existing file.
4. Register the directory via the 'SALOME_PLUGINS_PATH' environmental variable.

Usage

In the 'Mesh'-module of Salome, the plugin is accessible via the 'Tools' → 'Plugins' → 'Elmer' submenu.

Related topic on Elmer forum

http://www.elmerfem.org/forum/viewtopic.php?f=15&t=3636&sid=f5e1f9a49bfc587144d508fc8639596e
Some Remarks about the Plugin

Current Features

The plugin mimics the ElmerGUI in the context of the Salome platform. It provides the same functionality as the "Model"-menu in the ElmerGUI, allowing the definition of equations, material, boundary and body properties as well as simulation related parameters like time stepping, output file, etc.

Additionally, it provides a function that allows writing the settings into a .sif file that can be used as input for the ElmerSolver.
Some Remarks about the Plugin

Remarks and Limitations

Only for serial problems at the moment.
Attempts to read a sif file generates error.
Bodies and faces that shall be used for a simulation have to have a unique name without any blanks (e.g. 'Face 1' has to be 'Face1'). Ideally, these names are defined via the 'Group' function of SALOME. The plugin uses the 'Use Mesh Names'-options by default and ElmerGrid crops the names at the first occurrence of a blank.

In the SALOME's geometry module, give names to elements needed in setting boundary and initial conditions, like 'wall', 'opening', etc.. In the meshing module, use 'Create Groups from Geometry' tool to create groups for boundary and initial conditions.
Define first all boundary and initial conditions and then set them to desired boundaries with 'Properties of Selected Element' feature.